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TROUBLESHOOTING & HELPFUL HINTS 
Some common problems you may run into while using this program: 

● Drawing Lines that are too long, or wanting to trim lines that are too long 
Option 1: Click on the segment of the line, or the line you want to delete, then press the Delete key 
Option 2: You can use the Trim tool.  

● You want to Undo something you just did:  
Control-Z or undo button 

● While creating a sketch: If you want to go back and edit a sketch, accidentally have exited the sketch you were 
working on, you can right-click on the sketch’s name in the Model toolbar on the left side of your screen and 
select Edit Sketch. If the sketch hasn’t been “used” for something like an extrusion or revolution, you can click 
on any part of the sketch and select the Edit Sketch option from the Mini-Toolbar. 

 
Shortcut keys. Throughout the course of this tutorial, I have included only a few of the many useful keystrokes that can 
increase the speed at which you use Inventor. Some others you may find helpful are listed here for your reference.  

Sketching: Modeling: Assembling: 
D Dimension E Extrude P Place component  
X Trim C Constrain R Revolve 
L Line H Hole 

F Fillet 
 

Where am I looking? 
 

When you are building a part, you will need to look at faces and edges that won’t 
be visible in your current view. Using the ViewCube seen below, you can select any one of 
26 different views by clicking on the cube’s edges, corners, and faces. The house icon will 
return you to your home or “isometric” view.  
 

VIEWCUBE: used to change the  
view of the part you are working  
on.  

 
 
 
 
SHORTCUT KEYS: 
F6: Will return you to the ISOMETRIC view.  
F4: You can freely rotate your model by pressing and holding F4, and then clicking and 
dragging in your work area.  
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 SECTION 1: CREATING A PART 
1. Double click on Autodesk Inventor Professional 2018 on your desktop. 
2. Once Inventor has loaded, click on New located in the top left corner of the screen. 
3. In the New File window that opens, double click on Standard.ipt. You have now started a 

new part.  

 
4. To begin, you must first create a new sketch. Click on Start 2D Sketch in the top left corner. Select 

the XY Plane highlighted in dark orange in FIGURE 1. Notice that the toolbar on the top has now 
switched to the Sketch Toolbar. 

5. In the Sketch toolbar, click on the Line tool. 
6. To use the line tool, click once where you want the line to begin, and then click again where you want it to end. Notice 

that after ending the first line, the line tool will start the next line at the endpoint of the first line. To start a line at the 
origin, move your cursor over to the yellow point in the middle of your workspace. You will notice the origin turn a 
bright green color when you are over it. At this point, you can click once to select it. Now, using the line tool and 
starting at the origin, make the shape shown in FIGURE 2.1 above.  

NOTE: It is OK if your shape does not appear exactly as shown in FIGURE 2.1, however you should have the same 
general shape. Your sketch will look more like the shape in FIGURE 2.1 after you dimension it in step 7 below. 

7. In the Sketch toolbar, click on the Dimension tool  
● Move the pointer over a line to highlight it, and then click the line to create a dimension. 

Move your cursor away from the line you selected, and then click again to place the 
dimension. A new box will open and allow you to edit the new dimension. 

● Type the new dimension in the box and click on the green checkmark to create it. 
● Dimension the shape as shown in FIGURE 2.2 above, where A=1”,  B, E=0.125”,  C, D=0.875”. and F=1”. 
● When you are done dimensioning, click on the green check mark in the sketch toolbar, or 

right click and select OK. 
8. Now click on the Fillet tool at the top of your screen.  

● The 2D Fillet menu will appear. Set the radius of your fillet to be  0.075”. 
● Click on the lines labeled “D” and “E” in FIGURE 2.2  above. Your sketch should now look like FIGURE 3. 
● Right click & select “Ok”.  

9. Exit the sketch by right-clicking, and selecting Finish 2D Sketch. The Sketch toolbar changes to the 3D Model toolbar 
10. Click on the Extrude tool located at the top of the 3D Model toolbar 

● Because you only have one sketch present in this part file, Inventor automatically selects 
the profile you have just created as the one that will be extruded. 

● Change the distance to 3” as shown in FIGURE 4. 
● Click the green check mark, or right click and select OK 

. 
11. Your part should now look like THIS → 
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The next step will be to create two holes on sides E and D, so that we can attach this part to others in a later assembly.  

12. You can also add a fillet once a sketch has been extruded. Select the Fillet tool from the 3D Model toolbar. Click on the 
edge indicated in RED in FIGURE 5 above. (This is the edge corresponding to the intersection of sides “E” and “D” in 
FIGURE 2 on the previous page) 

● In the Fillet Menu shown in FIGURE 7 above, dimension the fillet to be 0.075”. 
● Click OK add the new fillet. 

13. Now Right-Click on the face labeled “D” in FIGURE 5, and select New Sketch. 
● Using the VIEWCUBE, orient the part so that the rounded edge of face D is facing downward, and you are 

looking straight down at face D as displayed in FIGURE 6 (on the next page) by clicking on the arrow 
highlighted in blue in FIGURE 8 above. 

● Using the Circle tool, draw two circles anywhere on the part, as seen in FIGURE 6.  
● Click Dimension and select the center of the left circle and edge (A). Edit that dimension to be 0.75” and 

repeat it with the right circle and edge (B). Then click on the center of one of the circles and bottom edge (C) 
and edit the dimension to be 0.5” and repeat that process for the other circle.  

● Dimension the circles to have a diameter of 0.25”.  
● Exit the Sketch  

                    
14. Click on the Extrude tool, and click inside both circles to select them. 

● Select the Cut option as seen in FIGURE 9 above. These options are highlighted in 
BLUE as being selected.  

● Click the green check mark to cut the holes. 
15. Repeat steps 13 through 14, but now use the side labeled as “E” in FIGURE 5 
16. Your part should look like THIS → 

● Click on The Inventor icon in the top left corner of the screen (where you would normally 
fine the “File” menu in most other programs), click on Save, and save this as “PART 1” 

○ Create a folder on the desktop called Tutorial Part Files and save the part there. 
■ You will need to access the parts again. 
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SECTION 2: CREATING AN ASSEMBLY 
*There is a folder on your desktop home screen labeled “TUTORIAL PART FILES” that you will need to access 

during this section* 
. 

 
1. Go to File → New → Assembly, or alternatively if you were to click on the New button, you would select 

Standard.iam  
2. Click on Place, and then navigate to the TUTORIAL PART FILES folder on the desktop. 

● Double click on the part labeled Tutorial Part1. Click once to insert it into the document.  
● Repeat this for Part 1, and Tutorial Part2, double clicking to select the part, and once in the 

document to 
 place it. 

● Once you are done placing the above components, press the Escape key to exit the Place tool.  
3. Click on the Constrain tool. This is the tool that will be used to mate or to create a relationship 

between components. This will allow for the parts to be bound together so they don’t move or only 
move within certain parameters of each other. 

During this step, you will need to rotate your view so that you can select the different faces 
necessary to mate the components together. To rotate your view, you can either press and 

hold F4 and click and drag with your mouse, OR by using the viewcube. 
● STEP 1 – Joining “Part1” (FIGURES 10 & 11) and “TUTORIAL PART1” (FIGURE 12) 

i. To make a concentric mate between two holes, move your cursor over the first hole so 
that it is highlighted with a dashed line running through the center as shown in FIGURE 13 
above, and then click once to select the first hole, and repeat for the second hole. 
**IMPORTANT: in FIGURE 13, the dashed line is shown in red. You may have a different color 
dashed line. This is OK, what is important is that you have the DASHED line running through the 
center of the hole when you select it. DO NOT SELECT THE OUTER EDGE OF THE CIRCLE.** 

ii. Make a concentric mate to join Hole A in FIGURE 10 with hole H in FIGURE 12. Click Apply in the 
Constraint window, or hit the Enter key to apply the mate.  

iii. Make a concentric mate between hole B in FIGURE 10 and hole J in FIGURE 12. Apply the mate 
to complete it. 

iv. To mate part faces together, click once on the first face, and then click once on the second face. 
Mate face E in FIGURE 11 and face G in FIGURE 12. Apply the mate to complete it.  

● STEP 2 – Joining “Part1” and “TUTORIAL PART2” 
        i. This is done using the same methods used in Step 1  

1. Your final assembly should look like THIS →  
● Save this as “FRAME ASSEMBLY” 
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SECTION 3: CREATING A BOLTED CONNECTION 

 
1. While you still have your assembly open, click on the Design tab located next to Assemble in the top left of 

the screen, and then select Bolted Connection. The Bolted Connection Component Generator opens. 
● Under the Placement menu, click on the drop down menu, and change the selection from Linear to 

Concentric. 
● For the start plane, select face A in FIGURE 14. For the circular reference, select hole B in FIGURE 

14 **IMPORTANT** make sure you select the INSIDE FACE of hole B! This is done the same way 
you selected the hole when making a concentric mate.  For the termination point, select face C in 
FIGURE 15 above 

● For this bolted connection, go to the diameter drop down menu and select 0.25 in. 
● Next, select Click to add Fastener, change the category to Hex Head Bolt, and select Hex Bolt – 

Inch. 
● Again, select Click to add Fastener, scroll down to row 4, and select Plain Washer (Inch) 
● Select the second available option for Click to add Fastener, change the category from Washers to 

Nuts, and select Hex Nut – Inch.  
● The selected options for your bolt should appear as in Figure 16 above.  
● Click Apply, and select Ok when prompted to name your file. Your bolt will now appear in the 

assembly. 
 

2. Save this as BOLTED ASSEMBLY 1 
*You may notice that every time you select a component of the bolted connection you are building, that a green 

“wire frame” outline of that component will appear on the assembly as a preview of what you are doing. 
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SECTION 4: DOWNLOADING PARTS FROM THE INTERNET 
 

AUTODESK.COM provides part files for the FRC Kit of Parts in either the native Inventor format or the STEP format. 
Below are instructions on how to download and make available the 2014 Kit of Parts. The same steps can be followed for 
the 2018 Kit of Parts once it becomes available. 
 
NOTE: Because this file is very large, it is already downloaded and extracted for you. The extracted folder is called 
FIRST-2014-KOP-1-17-2014 and is located in the TUTORIAL PART FILES→ DOWNLOADS folder. The following steps are 
instructions on how to download the Kit of Parts file in the future. 

 
1. Open Internet Explorer, and go to 

http://www.autodesk.com/education/competitions-and-events/first/recommended-softwar
e  

2. Scroll down to the Additional Resources section and locate the 2014 Kit of Parts. 
● You can download the Kit of Parts in the Inventor or .STEP formats. 
● The downloaded .ZIP file will have to be extracted to a specific location before the files can                 

be used in Inventor. 
3. To extract the downloaded .ZIP file, right-click on the folder labeled FRC_KOP_2014 and select 

Extract To (TUTORIAL PART FILES/DOWNLOADS)→Next→Next and then Finish. Now the parts 
are accessible in Inventor.  

 
OPTIONAL: BOSTONGEAR.COM is a useful site for spur/bevel/helical/miter/ & worm gears, couplings, and bushings. 
Below are instructions on how to download and make available the files from this site: 

 
1. Open Internet Explorer,  and go to http://www.bostongear.com/  
2. Click on BostSpec 2. 
3. Once you are registered, you can select a product category from the list on the left hand side of the                    

screen.  
Ex: I want to find a spur gear. So I would click on Open Gearing in the list on the left                     
hand side of the screen (a new sub-list appears). I then click on the + sign next to Spur                   
Gears, and then click on Spur Gears. I then click on Product Selector to bring me to a                  
list of all the gears the company stocks.  

(Open Gearing>> Spur Gears>> Spur Gears>> Product Selector) 
4. To download a part file 

● Click on the BLUE part number for the gear you want 
● Select a format to download the part file in, I would suggest STEP (.step), and save the file 

with the rest of your parts. 
● Extract the part file as you did when downloading the Autodesk Kit of Parts. 

5. In Autodesk Inventor, click on File→Open→ (Folder where all your files are saved) 
● Change the Files of Type menu to All Files (*.*) 
● Double click on the file you downloaded.  
● Save the file so that it becomes a .ipt file that you can access and modify using Inventor, by 

going to File→Save as, and saving the file to your folder.  
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SECTION 5: DRAWINGS 
BASIC STANDARDS 

Drawings are an essential part of the Design Team’s contributions to the build process. 3D CAD Models can be used to create 
drawings which are used for creating the physical part. It is important to have drawings standards to avoid confusion and 
inconsistency. 

RECOMMENDED UNIVERSAL STANDARDS: 

● Every drawing is made to fit a standardized size for printing. 
● Drawings should always use an unique template which has a proper title block. Teams should have customized 

templates that showcase their team logo and FRC involvement. 
● The Template Title Block should include areas for: 

○ Part name Should follow team’s naming standards/part catalogue 

○ Drawing author Allows build team to have a person to consult with questions about the 
part 

○ Date of drawing creation Helps prevent use of outdated drawings 

○ Scale of drawing Important to maintain accuracy of drawings 

○ Revision number Helps prevent use of outdated drawings and allows for comparison of
different part iterations as it is modified 

FRC TEAM 1403 DRAWING STANDARDS: 

● A standard drawing is 11” x 17” with a landscape orientation. 
● Always use the specific FRC Cougar Robotics Drawing Template. The template includes both the Team 1403 Cougar 

Robotics logo and the FRC logo in the title block. 
● It is customary to use a minimum of 3 views of the part, 2 of them being 2D views for mesurements and 1 being a 

3D projected view to give a sense of what the part looks like. 
○ More than 3 views can be used to properly define a part 

● Annotations must be consistent 
○ Dimensions must be accurate to 3 decimal places. See reference A in FIGURE 39 on the next page. 
○ Centers of holes must be marked and the dimensions should start from there (reference B). 
○ Always dimension the measurements from the same corner to make the part easier to create/cut 

(reference C). 
○ If multiple holes in a part share the same diameter, make sure to put in the “TYP” note next to the 

dimension (reference D). 
● A revision note should be added after the drawing is initially made, then changed for the amount of times the 

drawing has been changed or modified no matter how small or large the modification 
● Always follow the part-naming system to make it easier to catalogue and organize the parts. 

○ Format should be: Source/Vendor.SubassemblyCode.PartTypeCode.RRevision#[Descriptive Part Name] 
● (e.g.) 1403.DT.11.R2 [2 x 1 x 24 in. Drive Train Block] 

● Figure 39 on the following page shows an example of a standard Team 1403 drawing 
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FIGURE 39  
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CREATING A DRAWING: 

1. Open the Print Template file located in the TUTORIAL PART FILES folder on the desktop and, before 
continuing, SAVE AS  [TeamNumberDrawingWKSHP] (e.g. Team1403DrawingWKSHP). 
**DO NOT CLICK SAVE** 

2. Click on BASE in the upper left corner. Then, click on the button to the right of the file directory and open 
PART 1 (saved wherever you saved it during Section 1). 

● Note: If a part is open in another tab, it will automatically be selected. 
3. The part will appear in the center of the screen in the front view. Adjust it so that it is in the Right view. In 

the bottom right of the window, you can adjust the scale to change the size of the drawing. Set the scale to 
2 : 1. Your window should look like FIGURE 40. 

4. Click on PROJECTED in the upper left corner. 
● Moving the mouse around the view will allow you to change the angle from which the part is viewed. 

5. Create at least 3 views (use FIGURE 39 as a reference), then right click and select OK. 
6. Click on the DIMENSION tool to begin annotating.  

● With this tool, you can annotate various measurements and dimensions the same 
way you would dimension a sketch. 

● Annotate the drawing to match FIGURE 39. 
● (Note: when annotating circles, select the outer rim so that a green dot does not 

appear) 
7. Use the CENTER MARK tool in the Symbols section of the toolbar (highlighted in red below) to indicate the centers 

of the holes. Mark the two holes in the center view just like in FIGURE 39. 
8. When dimensioning the circles, make sure to add “TYP” to indicate when 

holes in the part share the same dimensions 
9. Make sure to annotate any fillets as well (add “TYP” to indicate fillets with 

the same dimensions) 
10. You now have enough dimensions annotated to recreate the part. 

● Your drawing should look similar to FIGURE 39. 

NOTE: Make sure to make enough annotations so that somebody can recreate the part using the dimensions! 

 

Congratulations!!! You have completed the Beginner packet.  If you are up for the 
challenge then you can now move on to the Advanced Section of the Autodesk 

inventor Tutorial.  
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WHAT’S NEW IN AUTODESK INVENTOR 2018 
 
Model-based definition: 

Model-Based Definition (MBD), is a powerful new set of tools for adding annotations, 
GD&T, and other manufacturing information directly to a 3D part. The integrated Tolerance 
Advisor checks the health of your tolerance scheme and lists potential problems, errors, and other 
information in the Tolerance Advisor browser.  

● Once your 3D model has MBD and 3D Annotations applied you can recover in your 
2D drawing, export in a 3D PDF or STEP AP242. 

 
 
 
 

 

 
 
 
 
 
 
 
 
Browser Tools: 
Save time with the exciting new browser tools. 

● Find things quickly and easily in the current active 
document with the new browser search. 

● In an assembly file, use the filter tools   to 
narrow your search (not available in Inventor LT). 

● Move and dock each tab to your preferred way of working. The following image is an 
example of side-by-side docking. 
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AnyCAD: 

● With Inventor 2017.4, AnyCAD has been expanded to allow you to leverage Inventor 2018 

files in your Inventor 2017 designs.  

○ This means you can now work with others who are on versions of Inventor that are 

earlier or later than the version you are working in. To help you identify the version 

of an Inventor file, the Open dialog now displays Inventor version a file was last 

saved in. 

 

 

 

 

 

 

New and Improved Measure Workflows and Graphics 

The Inventor measure tools and workflows have been greatly simplified and improved to enhance 
productivity. You can now: 

● Use a single measure command! 
● Perform all measure workflows from the new measure tool panel. 
● Display rich information for each selection with a single click. 
● Easily measure angles and identify measure selections in the graphics window. 
● Easily identify measure selections in the graphics window. 
● Additional productivity enhancements. 
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DWG Underlay: 

New DWG Underlay features make working with DWGs faster. 

● Import your DWG file directly into an assembly using the Place Components command. 

● Select multiple DWG Files when creating more than one underlay. 

● Open an AutoCAD DWG file directly from the right-click context menu in your part or 

assembly model browser node in Inventor. 

● Automatically project certain types of DWG geometry when you enable the new 

Application Options   Sketch   Autoproject edges during curve creation option. 

● If the selected DWG Underlay geometry is within the XY, YZ, or XZ plane, the resulting 

joint is created on the same plane as the sketch in the same way a joint is created 

between 2D Inventor geometry. 

● Create a joint on the same plane as the sketch in the same way a joint is created 

between 2D Inventor geometry: If the selected DWG Underlay geometry is within the 

XY, YZ, or XZ plane, the resulting joint is created on the same plane as the sketch. 
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Part Creation: 

● Extrude:  

○ Use the new Distance from Face option in the Extrude 

dialog box to start an extrusion from a face or workplane 

with a distance. Because Distance from Face creates one 

central entry point for modifying the geometry, no 

additional steps to make sketches or workplanes are 

needed. 

● Chamfer:  

○ You can now create a chamfer that does not require an 

entire edge. A new tab, Partial, is added to the Chamfer 

dialog box to support the creation of partial chamfers. 

● Hole: 

○ You can now create a symmetric hole type that 

extrudes in two directions. The Flip Termination 

button is replaced with Direction1 and 

Direction 2 buttons. The Symmetric distance 

is only available for the Drilled - Simple Hole - 
Through All hole type. 

○ You can now specify zero (0) as a value for 

bore depth on Spotface holes. As a result, 

you can now place a spotface hole on the 

termination face of a body. 

○ Use the new option, Extend Start, on the 

Hole dialog box to extend the start face of a 

hole to the first place where there is no 

intersection with the target body. The 

purpose of Extend Start is to remove a 

fragment resulting from the creation of the 

hole. 
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Presentation updates: 
Presentation documents now provide more robust support for surface bodies: 

You can: 

● Use window selection to select multiple surface bodies. 

● Use the Tweak command to move surface bodies. 

● Use surface geometry to orient and position the Tweak triad. 
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